const regex = /\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[url=\\"([^\\s"]+?)\\"\\](.+?)\\[\\\/url\\]', 's')
const str = `[url="https://wordpress.org/"]Обычная ссылка[/url]
[url="https://wordpress.org/" target="_blank"]Обычная ссылка в новом окне[/url]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}