// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]"#).unwrap();
let string = "[url=\"https://wordpress.org/\"]Обычная ссылка[/url]
[url=\"https://wordpress.org/\" target=\"_blank\"]Обычная ссылка в новом окне[/url]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}