package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]`)
var str = `[url="https://wordpress.org/"]Обычная ссылка[/url]
[url="https://wordpress.org/" target="_blank"]Обычная ссылка в новом окне[/url]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}