$re = '/\[url=\"([^\s"]+?)\"\](.+?)\[\/url\]/s';
$str = '[url="https://wordpress.org/"]Обычная ссылка[/url]
[url="https://wordpress.org/" target="_blank"]Обычная ссылка в новом окне[/url]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);