#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z'-]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z'-]+"
Local $sString = "my cat is going to the vet in wilkes-barre." & @CRLF & _
"" & @CRLF & _
"my cat isn't going to the vet today." & @CRLF & _
"" & @CRLF & _
"doesn't your cat need to get a needle soon?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")