using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z'-]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z'-]+";
string input = @"my cat is going to the vet in wilkes-barre.
my cat isn't going to the vet today.
doesn't your cat need to get a needle soon?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}