re = /^[a-z'-]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z'-]+/m
str = 'my cat is going to the vet in wilkes-barre.
my cat isn\'t going to the vet today.
doesn\'t your cat need to get a needle soon?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end