const regex = new RegExp('^[a-z\\'-]+|\\b(?|my|is|to|the)\\b(*SKIP)(*FAIL)|[a-z\\'-]+', 'gm')
const str = `my cat is going to the vet in wilkes-barre.
my cat isn't going to the vet today.
doesn't your cat need to get a needle soon?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}