package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z'-]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z'-]+`)
var str = `my cat is going to the vet in wilkes-barre.
my cat isn't going to the vet today.
doesn't your cat need to get a needle soon?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}