import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z'-]+|\\b(?|my|is|to|the)\\b(*SKIP)(*FAIL)|[a-z'-]+";
final String string = "my cat is going to the vet in wilkes-barre.\n\n"
+ "my cat isn't going to the vet today.\n\n"
+ "doesn't your cat need to get a needle soon?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}