#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$"
Local $sString = "-0" & @CRLF & _
"0.0001" & @CRLF & _
"0123456789.1234" & @CRLF & _
"007" & @CRLF & _
"+0.1" & @CRLF & _
"+123456789.1234" & @CRLF & _
".1234" & @CRLF & _
"1." & @CRLF & _
"" & @CRLF & _
"-0.1" & @CRLF & _
"-0.12" & @CRLF & _
"-0.123" & @CRLF & _
"-0.1234" & @CRLF & _
"-1" & @CRLF & _
"-1.1" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"+" & @CRLF & _
"-0" & @CRLF & _
"0123456789.1234" & @CRLF & _
"007" & @CRLF & _
"+0.1" & @CRLF & _
"+123456789.1234" & @CRLF & _
".1234" & @CRLF & _
"1." & @CRLF & _
"" & @CRLF & _
"-123456789.1234" & @CRLF & _
"1233213.12321"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")