import re
regex = re.compile(r"^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$", flags=re.MULTILINE)
test_str = ("-0\n"
"0.0001\n"
"0123456789.1234\n"
"007\n"
"+0.1\n"
"+123456789.1234\n"
".1234\n"
"1.\n\n"
"-0.1\n"
"-0.12\n"
"-0.123\n"
"-0.1234\n"
"-1\n"
"-1.1\n\n"
"-\n"
"+\n"
"-0\n"
"0123456789.1234\n"
"007\n"
"+0.1\n"
"+123456789.1234\n"
".1234\n"
"1.\n\n"
"-123456789.1234\n"
"1233213.12321")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")