// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$").unwrap();
let string = "-0
0.0001
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-123456789.1234
1233213.12321";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}