import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?0\\.\\d{1,4}|-?[1-9]\\d*(\\.\\d{1,4})?)$";
final String string = "-0\n"
+ "0.0001\n"
+ "0123456789.1234\n"
+ "007\n"
+ "+0.1\n"
+ "+123456789.1234\n"
+ ".1234\n"
+ "1.\n\n"
+ "-0.1\n"
+ "-0.12\n"
+ "-0.123\n"
+ "-0.1234\n"
+ "-1\n"
+ "-1.1\n\n"
+ "-\n"
+ "+\n"
+ "-0\n"
+ "0123456789.1234\n"
+ "007\n"
+ "+0.1\n"
+ "+123456789.1234\n"
+ ".1234\n"
+ "1.\n\n"
+ "-123456789.1234\n"
+ "1233213.12321";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}