re = /^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$/m
str = '-0
0.0001
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-123456789.1234
1233213.12321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end