const regex = /^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?0\\.\\d{1,4}|-?[1-9]\\d*(\\.\\d{1,4})?)$', 'gm')
const str = `-0
0.0001
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-123456789.1234
1233213.12321`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}