package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?0\.\d{1,4}|-?[1-9]\d*(\.\d{1,4})?)$`)
var str = `-0
0.0001
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-0.1
-0.12
-0.123
-0.1234
-1
-1.1
-
+
-0
0123456789.1234
007
+0.1
+123456789.1234
.1234
1.
-123456789.1234
1233213.12321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}