#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=-)([^_]+)_([^\.]+)"
Local $sString = "-cloth_ball.properties" & @CRLF & _
"-cloth_puppet.properties" & @CRLF & _
"-plastic_ball.properties" & @CRLF & _
"-plastic_puppet.properties" & @CRLF & _
"-wooden_ball.properties" & @CRLF & _
"-wooden_puppet.properties"
Local $sSubst = "$2_$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)