$re = '/(?<=-)([^_]+)_([^\.]+)/m';
$str = '-cloth_ball.properties
-cloth_puppet.properties
-plastic_ball.properties
-plastic_puppet.properties
-wooden_ball.properties
-wooden_puppet.properties';
$subst = "$2_$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;