use strict;
my $str = '-cloth_ball.properties
-cloth_puppet.properties
-plastic_ball.properties
-plastic_puppet.properties
-wooden_ball.properties
-wooden_puppet.properties';
my $regex = qr/(?<=-)([^_]+)_([^\.]+)/mp;
my $subst = '$2_$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";