re = /(?<=-)([^_]+)_([^\.]+)/m
str = '-cloth_ball.properties
-cloth_puppet.properties
-plastic_ball.properties
-plastic_puppet.properties
-wooden_ball.properties
-wooden_puppet.properties'
subst = '$2_$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result