# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=-)([^_]+)_([^\.]+)"
test_str = ("-cloth_ball.properties\n"
"-cloth_puppet.properties\n"
"-plastic_ball.properties\n"
"-plastic_puppet.properties\n"
"-wooden_ball.properties\n"
"-wooden_puppet.properties")
subst = "$2_$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.