const regex = new RegExp('(?<=-)([^_]+)_([^\\.]+)', 'gm')
const str = `-cloth_ball.properties
-cloth_puppet.properties
-plastic_ball.properties
-plastic_puppet.properties
-wooden_ball.properties
-wooden_puppet.properties`;
const subst = `$2_$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);