import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=-)([^_]+)_([^\\.]+)";
final String string = "-cloth_ball.properties\n"
+ "-cloth_puppet.properties\n"
+ "-plastic_ball.properties\n"
+ "-plastic_puppet.properties\n"
+ "-wooden_ball.properties\n"
+ "-wooden_puppet.properties";
final String subst = "$2_$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}