# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\\/?(?!i>)\w+.*?>//g;t' <<< "<span> </span><span class=\"citation_text\" id=\"_148511159\">Rawls, Wilson.
<i>Where the Red Fern Grows: The Story of Two Dogs and a Boy</i>. Garden City, NY: Doubleday, 1961. Print.</span>"