use strict;
my $str = '<span> </span><span class="citation_text" id="_148511159">Rawls, Wilson.
<i>Where the Red Fern Grows: The Story of Two Dogs and a Boy</i>. Garden City, NY: Doubleday, 1961. Print.</span>';
my $regex = qr/<\/?(?!i>)\w+.*?>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";