const regex = /<\/?(?!i>)\w+.*?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?(?!i>)\\w+.*?>', 'g')
const str = `<span> </span><span class="citation_text" id="_148511159">Rawls, Wilson.
<i>Where the Red Fern Grows: The Story of Two Dogs and a Boy</i>. Garden City, NY: Doubleday, 1961. Print.</span>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);