using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?(?!i>)\w+.*?>";
string substitution = @"";
string input = @"<span> </span><span class=""citation_text"" id=""_148511159"">Rawls, Wilson.
<i>Where the Red Fern Grows: The Story of Two Dogs and a Boy</i>. Garden City, NY: Doubleday, 1961. Print.</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}