re = /<\/?(?!i>)\w+.*?>/
str = '<span> </span><span class="citation_text" id="_148511159">Rawls, Wilson.
<i>Where the Red Fern Grows: The Story of Two Dogs and a Boy</i>. Garden City, NY: Doubleday, 1961. Print.</span>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result