import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\"(?:[A-Z]|[a-z])[a-z]{3,}\"\\)";
final String string = "\n\n"
+ "words.Add(\"McLaren\");//false\n"
+ "words.Add(\"Nissan\");//true\n"
+ "words.Add(\"BMW\");//false\n"
+ "words.Add(\"Subaru\");//true\n"
+ "words.Add(\"Maserati\");//true\n"
+ "words.Add(\"Mercedes Benz\");//false\n"
+ "words.Add(\"Volkswagen\");//true\n"
+ "words.Add(\"audi\");//true\n"
+ "words.Add(\"Alfa Romeo\");//false\n"
+ "words.Add(\"rollsRoyce\");//false\n"
+ "words.Add(\"drive\");//true";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}