const regex = /\("(?:[A-Z]|[a-z])[a-z]{3,}"\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\("(?:[A-Z]|[a-z])[a-z]{3,}"\\)', 'g')
const str = `
words.Add("McLaren");//false
words.Add("Nissan");//true
words.Add("BMW");//false
words.Add("Subaru");//true
words.Add("Maserati");//true
words.Add("Mercedes Benz");//false
words.Add("Volkswagen");//true
words.Add("audi");//true
words.Add("Alfa Romeo");//false
words.Add("rollsRoyce");//false
words.Add("drive");//true`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);