import re
regex = re.compile(r"\(\"(?:[A-Z]|[a-z])[a-z]{3,}\"\)")
test_str = ("\n\n"
"words.Add(\"McLaren\");//false\n"
"words.Add(\"Nissan\");//true\n"
"words.Add(\"BMW\");//false\n"
"words.Add(\"Subaru\");//true\n"
"words.Add(\"Maserati\");//true\n"
"words.Add(\"Mercedes Benz\");//false\n"
"words.Add(\"Volkswagen\");//true\n"
"words.Add(\"audi\");//true\n"
"words.Add(\"Alfa Romeo\");//false\n"
"words.Add(\"rollsRoyce\");//false\n"
"words.Add(\"drive\");//true")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)