#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bshare\\([^\\]+)"
Local $sString = "\server\share\folder1\subfolder1" & @CRLF & _
"\server\share\folder1\subfolder1\subfolder2" & @CRLF & _
"\server\share\complex\subfolder1" & @CRLF & _
"\server\share\5555AB12\subfolder1\subfolder2\subfolder3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")