// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bshare\\([^\\]+)").unwrap();
let string = "\\server\\share\\folder1\\subfolder1
\\server\\share\\folder1\\subfolder1\\subfolder2
\\server\\share\\complex\\subfolder1
\\server\\share\\5555AB12\\subfolder1\\subfolder2\\subfolder3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}