$re = '/\bshare\\\\([^\\\\]+)/m';
$str = '\\server\\share\\folder1\\subfolder1
\\server\\share\\folder1\\subfolder1\\subfolder2
\\server\\share\\complex\\subfolder1
\\server\\share\\5555AB12\\subfolder1\\subfolder2\\subfolder3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);