using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bshare\\([^\\]+)";
string input = @"\server\share\folder1\subfolder1
\server\share\folder1\subfolder1\subfolder2
\server\share\complex\subfolder1
\server\share\5555AB12\subfolder1\subfolder2\subfolder3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}