use strict;
my $str = '\\server\\share\\folder1\\subfolder1
\\server\\share\\folder1\\subfolder1\\subfolder2
\\server\\share\\complex\\subfolder1
\\server\\share\\5555AB12\\subfolder1\\subfolder2\\subfolder3';
my $regex = qr/\bshare\\([^\\]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}