package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bshare\\([^\\]+)`)
var str = `\server\share\folder1\subfolder1
\server\share\folder1\subfolder1\subfolder2
\server\share\complex\subfolder1
\server\share\5555AB12\subfolder1\subfolder2\subfolder3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}