re = /\bshare\\([^\\]+)/m
str = '\\server\\share\\folder1\\subfolder1
\\server\\share\\folder1\\subfolder1\\subfolder2
\\server\\share\\complex\\subfolder1
\\server\\share\\5555AB12\\subfolder1\\subfolder2\\subfolder3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end