# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/background=['"](?!\s*(http|ftp):\\/\\/)\\/?(?<filename>[^'"]*)['"]/\/mydir\/${filename}/gm;t' <<< "background=\"image.gif\"
background=\"/image.gif\"
background=\"images/image.gif\"
background=\"http://host/images/directory/image.gif\"
background=\"images/directory/image.gif\"
background='image.gif'
background='/image.gif'
background='images/image.gif'
background='http://host/images/directory/image.gif'
background='/images/directory/image.gif '
background=''
background=' http://host/images/directory/image.gif '
background='test/http://host/images/directory/image.gif'"