#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)background=['"](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'"]*)['"]"
Local $sString = "background="image.gif"" & @CRLF & _
"background="/image.gif"" & @CRLF & _
"background="images/image.gif"" & @CRLF & _
"background="http://host/images/directory/image.gif"" & @CRLF & _
"background="images/directory/image.gif"" & @CRLF & _
"background='image.gif'" & @CRLF & _
"background='/image.gif'" & @CRLF & _
"background='images/image.gif'" & @CRLF & _
"background='http://host/images/directory/image.gif'" & @CRLF & _
"background='/images/directory/image.gif '" & @CRLF & _
"background=''" & @CRLF & _
"background=' http://host/images/directory/image.gif '" & @CRLF & _
"background='test/http://host/images/directory/image.gif'"
Local $sSubst = "/mydir/${filename}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)