using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"background=['""](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'""]*)['""]";
string substitution = @"/mydir/${filename}";
string input = @"background=""image.gif""
background=""/image.gif""
background=""images/image.gif""
background=""http://host/images/directory/image.gif""
background=""images/directory/image.gif""
background='image.gif'
background='/image.gif'
background='images/image.gif'
background='http://host/images/directory/image.gif'
background='/images/directory/image.gif '
background=''
background=' http://host/images/directory/image.gif '
background='test/http://host/images/directory/image.gif'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}