# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"background=['\"](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'\"]*)['\"]"
test_str = ("background=\"image.gif\"\n"
"background=\"/image.gif\"\n"
"background=\"images/image.gif\"\n"
"background=\"http://host/images/directory/image.gif\"\n"
"background=\"images/directory/image.gif\"\n"
"background='image.gif'\n"
"background='/image.gif'\n"
"background='images/image.gif'\n"
"background='http://host/images/directory/image.gif'\n"
"background='/images/directory/image.gif '\n"
"background=''\n"
"background=' http://host/images/directory/image.gif '\n"
"background='test/http://host/images/directory/image.gif'")
subst = "/mydir/${filename}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.