re = /background=['"](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'"]*)['"]/m
str = 'background="image.gif"
background="/image.gif"
background="images/image.gif"
background="http://host/images/directory/image.gif"
background="images/directory/image.gif"
background=\'image.gif\'
background=\'/image.gif\'
background=\'images/image.gif\'
background=\'http://host/images/directory/image.gif\'
background=\'/images/directory/image.gif \'
background=\'\'
background=\' http://host/images/directory/image.gif \'
background=\'test/http://host/images/directory/image.gif\''
subst = '/mydir/${filename}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result