use strict;
my $str = 'background="image.gif"
background="/image.gif"
background="images/image.gif"
background="http://host/images/directory/image.gif"
background="images/directory/image.gif"
background=\'image.gif\'
background=\'/image.gif\'
background=\'images/image.gif\'
background=\'http://host/images/directory/image.gif\'
background=\'/images/directory/image.gif \'
background=\'\'
background=\' http://host/images/directory/image.gif \'
background=\'test/http://host/images/directory/image.gif\'';
my $regex = qr/background=['"](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'"]*)['"]/mp;
my $subst = '/mydir/${filename}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";