package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}" *\+ *(val.imageLink) *\+ *" *'{0,1} *>";`)
var str = `html+= "<img src='"+val.imageLink+"'>";
html += "<img src ='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink +" ' >";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+="<img src='>"+val.imageLink+"'>";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}