import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(html) *(\\+=) *\\\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}\" *\\+ *(val.imageLink) *\\+ *\" *'{0,1} *>\";";
final String string = "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html += \"<img src ='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink +\" ' >\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n"
+ "html+= \"<img src='\"+val.imageLink+\"'>\";\n\n\n"
+ "html+=\"<img src='>\"+val.imageLink+\"'>\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}