re = /(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}" *\+ *(val.imageLink) *\+ *" *'{0,1} *>";/
str = 'html+= "<img src=\'"+val.imageLink+"\'>";
html += "<img src =\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink +" \' >";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+= "<img src=\'"+val.imageLink+"\'>";
html+="<img src=\'>"+val.imageLink+"\'>";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end