// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}" *\+ *(val.imageLink) *\+ *" *'{0,1} *>";"#).unwrap();
let string = "html+= \"<img src='\"+val.imageLink+\"'>\";
html += \"<img src ='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink +\" ' >\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+= \"<img src='\"+val.imageLink+\"'>\";
html+=\"<img src='>\"+val.imageLink+\"'>\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}