const regex = /(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}" *\+ *(val.imageLink) *\+ *" *'{0,1} *>";/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(html) *(\\+=) *\\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *\'{0,1}" *\\+ *(val.imageLink) *\\+ *" *\'{0,1} *>";', 'g')
const str = `html+= "<img src='"+val.imageLink+"'>";
html += "<img src ='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink +" ' >";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+= "<img src='"+val.imageLink+"'>";
html+="<img src='>"+val.imageLink+"'>";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}